Start a new topic

Customize the bibtex entry when exporting

There should be a setting to customize the bibtex entry when exporting.

For example, I really don't want local-url in my bibtex file. But I don't know how to get rid of it.

35 people like this idea

I usually don't need the abstract exported in the bibtex entry, either.  Additionally, the auto key generation, which currently uses the doi, is quite unwieldy when working with the reference in latex.  While I know you can manually enter keys, there really should be the option to generate keys in some simple fashion (i.e., author_year, or some such).  For instance, the key generation in the old Papers application was quite reasonable.

8 people like this

We currently have implemented the Citekey generation. While this doesn't solve everything for this ticket it does solve the issue of citekeys being the DOI if that is not what you wanted.

1 person likes this

Also, it would be really great if one could copy the bibtex record to the clipboard in addition to exporting it to an external file. That way it would be easy to append the record to the existing bibtex library (by pasting it), for example. Another option would be to append the bibtex record to an existing file.

3 people like this

This has been implemented. You can now right click and copy 1 reference or several references to your clipboard

We really need the ability to customize which Bibtex fields are exported, because the "extra" fields (such as local file) often contain extraneous characters that cause errors in subsequent processing (the % character is particularly problematic). As it stands, I have to edit every .bib file generated by Papers to remove this stuff.

9 people like this

This really needs immediate attention.

Having to manually edit the exported .bib files such that they work in any other software defeats the whole point of using a bib to automate citations.

The following is a concrete example:

year = {1953},
title = {{Some experiments on the recognition of speech with one and two ears}},
author = {Cherry, Colin E.},
journal = {The Journal of the Acoustical Society of America},
local-url = {file://localhost/C:\Users\name\Documents\foldername%20Desktop\Cherry_1953%20some%20experiements%20on%20the%20recogntition%20of%20speech%20with%20one%20and%20two%20ears.pdf}

As stated by Todd, everything after the initial % is commented out. Consequently, the entry field is not encapsulated correctly with the required '}'.
I think we can live with the mess of having the local-url, so long as it doesn't corrupt the file format.

Exporting the local URL as a string " ", should be a quick fix.
Such a feature would be a make-or-break in determining if I purchase after the trial period.

20 people like this
Login or Signup to post a comment